Welcome to RailsBump! 👋

RailsBump lets you check your Ruby gems for compatibility with all major Rails versions. This is useful if you're planning to upgrade a Rails app to the next major version. You can either check an individual gem or a whole Bundler lockfile (Gemfile.lock).
Read more about how it works and the history of this project on GitHub and please open an issue if you encounter a problem.

This project is sponsored by FastRuby.io. They are a team of Ruby on Rails experts that specialize in Rails Upgrade Services.

Check a gem Check a lockfile

Latest checked gems

Gem Compatible with...
Rails 2.3 Rails 3.2 Rails 4.2 Rails 5.2 Rails 6.0
zlib all all all all all
verbs <= 2.0.3 all some all all
smtpapi all all all all all
possibly all all all all all
orderly 0.0.2 all all all all
mini_exiftool all all all all all
httmultiparty none all all all all
filestack none all all all all
double_entry 0.0.1.pre some all all all
concise_logging 0.0.1 0.0.1 all 0.0.1, 1.0.1, 1.1.0 0.0.1, 1.0.1, 1.1.0
capybara_table none all all all all
aws-sdk-firehose none all all all all
zk none all all all all
rsolr-ext none all all all all
rsolr-cloud all all all all all
kaminari-bootstrap3 none all all all all
fuzzy-string-match_pure >= 0.9.3 all all all all
cookie_law all all all all all
zendesk_remote_auth 0.9.0 0.x, 1.1.0, 1.2.0 0.x, 1.1.0, 1.2.0 0.x, 1.1.0, 1.2.0 0.x, 1.1.0, 1.2.0
zendesk2 0.0.1 all all all all

Support

If you find RailsBump useful and would like to support the ongoing development, buy me a coffee or become a sponsor!